Back to overview
Degraded

Slow database queries

Jun 12 at 03:22pm WEST
Affected services
chatrank.ai
agent.chatrank.ai
app.chatrank.ai

Resolved
Jun 12 at 03:34pm WEST

The issue has been reported as resolved by the service provider

Created
Jun 12 at 03:22pm WEST

Some users are experiencing slow page load times on our dashboards.
The issue has been traced back to our database service provider neon https://neonstatus.com/aws-us-east-ohio/incidents/01JXJ807RBR8STE0417A2MS5K0#01JXJ807RBXTWJKKW42C0P3MRA