Back to overview
Downtime

Service outage

Jun 12 at 08:37pm WEST
Affected services
chatrank.ai
agent.chatrank.ai

Resolved
Jun 12 at 09:58pm WEST

Incident is resolved by third party

Created
Jun 12 at 08:37pm WEST

Cloudflare and Google Cloud outages are causing service disruptions for most users